FORUM CLASSIFIEDS DIFFLOCK.com Links & Networks
Forum Homepage
Log in
Profile
Search
Private Messages
Forum Members
Register
Classified Ads
Search Ads
Place New Ad
My ads
Place your classified
ads here for FREE
NB: Adverts placed in the general
forum areas will be deleted
Difflock Homepage
Online Shop
Contact Us
FAQ
Calendar
Garage
Facebook
Twitter
Youtube
Advertise With Us - Reach your target market by advertising on the Difflock.com forum.
Click here or call 0845 125 9407


G13BB jimny oil leak... now lack of power

 
 
Post new topic   Reply to topic    Difflock Forum Index -> Suzuki
View previous topic :: View next topic  
Author Message
kentm11
Just got MTs


Joined: 19 Feb 2013
Odometer: 107




PostPosted: Sun Aug 07, 2016 3:56 pm    Post subject: G13BB jimny oil leak... now lack of power Reply with quote

Hi all.

Usually a LR post but today its a Jimny one. Mainly because the LR has just destroyed its transfer box (800 replacement... )

Our little jimny is best part of bullet proof but recently there has been two things happening

1)oil leak (in LR terms its marking its teritory and letting you know you actually have oil) which I believe is coming from the metal blanking plate below the cam sensor housing.. does anyone know what this plate is doing? I had a look for g13bb engine in google and found its a big hole but appears to have no function. Please can anyone advise on this?

2) the other half says its lacking in topend power (she has owned it for 5 years so know what to expect).. ideas?

I have checked all electrical connections, airbox, plugs and anything else that would be linked to fuel or gas movement. We recently replaced the cat for the third one in 5 years and have de-gunked the inlet manifold (acetone, everything is tight again and was totally free of acetone before reinstalling) the back scilencer is also okay.

Incidently how long do you get out of you cam sensor? We get through 2 a year! Ideas on that would also be great !!

Cheers

Mike.


Last edited by kentm11 on Sun Aug 21, 2016 8:49 am; edited 1 time in total
Back to top
View user's profile Send private message
kentm11
Just got MTs


Joined: 19 Feb 2013
Odometer: 107




PostPosted: Sat Aug 13, 2016 10:10 am    Post subject: Reply with quote

Well I have answered one question of my own on the powerloss point,
The plug lead running to cyl 1 has broken down a little. New one ordered and the old one running a bit better since getting cleaned with contact cleaner.

Also inspected for exhaust blockages again and there isnt anything to say theres an issue.

I think the main problem was the plug lead was arking out against the head or against the top of the plug as the rubber seal at the bottom has split and so not making great reliable contact. Will update with any new findings.
Back to top
View user's profile Send private message
kentm11
Just got MTs


Joined: 19 Feb 2013
Odometer: 107




PostPosted: Fri Aug 19, 2016 8:04 pm    Post subject: Reply with quote

The plate blanks off water it turns out.... found out the "humm so lets take it off and see"

Still getting a lack of power but Rhinoview shows no issues in the MIL or the various parameters.

Ideas??
Back to top
View user's profile Send private message
kentm11
Just got MTs


Joined: 19 Feb 2013
Odometer: 107




PostPosted: Sat Aug 20, 2016 1:10 pm    Post subject: Reply with quote

Okay.. further information on the lack of power.

I have finally got out to repeat the same senario and discovered that

There is a lack of power in 4th and 5th from 2k up. In 1st-3rd shes fine.

Its like turbo lag in the land rover but what confuses me is its onky in 4th and 5th.

Ideas?
Back to top
View user's profile Send private message
kentm11
Just got MTs


Joined: 19 Feb 2013
Odometer: 107




PostPosted: Sat Aug 20, 2016 2:35 pm    Post subject: Reply with quote

Can also add that it takes 24.3 seconds to get to 60mph.

Done a compression test and all cylinders are at between 175 and 185psi.

Other than this issue she runs perfectly fine.

Thoughts??
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Difflock Forum Index -> Suzuki All times are GMT - 12 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot post calendar events in this forum
Oil Safe

Specialist Tools

Facebook

Adrian Flux 2019

Service Kits

Join our mailing list for upcoming events, special offers, discount coupons and expert advice on the latest 4x4 products!

* indicates required





    
Powered by phpBB © phpBB Group