FORUM CLASSIFIEDS DIFFLOCK.com Links & Networks
Forum Homepage
Log in
Profile
Search
Private Messages
Forum Members
Register
Classified Ads
Search Ads
Place New Ad
My ads
Place your classified
ads here for FREE
NB: Adverts placed in the general
forum areas will be deleted
Difflock Homepage
Online Shop
Contact Us
FAQ
Calendar
Garage
Facebook
Twitter
Youtube
Advertise With Us - Reach your target market by advertising on the Difflock.com forum.
Click here or call 0845 125 9407


WJ Grand Cherokee cuts out under 1k rpm

 
 
Post new topic   Reply to topic    Difflock Forum Index -> Jeep
View previous topic :: View next topic  
Author Message
ROCKATANSKY
Just got MTs


Joined: 10 Oct 2007
Odometer: 230
Location: SUFFOLK



PostPosted: Mon May 06, 2013 6:18 pm    Post subject: WJ Grand Cherokee cuts out under 1k rpm Reply with quote

My WJ (4.0 2002) will sometimes cut out under 1000 rpm when up to operating temp, but okay when cold. Any ideas?[/url]
Back to top
View user's profile Send private message
john1961
Gate Opener


Joined: 19 Jan 2013
Odometer: 33




PostPosted: Fri May 10, 2013 8:40 pm    Post subject: Reply with quote

when its cold it runs with the cold start device activated ( over rich mixture ) when it gets warm the device is de activated (mixture is normal ) an air leak in the induction (intake system/manifold ) causes the fuel/air mixture to run weak ,the engine does not receive enough fuel to keep it running at low eng speed (tick over) as engine rpm is increased the mixture ratio is automatically made richer overcoming the air leak and so runs ok .
Look for air leaks around the air intake pipes after the air flow meter and also around the intake manifold joints ........as long as there are no warning lights on ,the electrical side of the fuel system should be ok ?????
Well its a starting point !!!!
Back to top
View user's profile Send private message
ROCKATANSKY
Just got MTs


Joined: 10 Oct 2007
Odometer: 230
Location: SUFFOLK



PostPosted: Wed May 15, 2013 4:56 am    Post subject: Reply with quote

Got it. It was throttle sensor. For some reason, when hot, the voltage a t the sensor dropped to 1.2v when throttle closed but 5v when opened, which is what it should be when closed. Strange it only done it when warm tho
Back to top
View user's profile Send private message
angel10
Gate Opener


Joined: 11 Oct 2014
Odometer: 1




PostPosted: Sat Oct 11, 2014 11:41 am    Post subject: Reply with quote

I have a spare (in Essex), but what style are your's?
__________________________________
We are the pioneers in Pass4sure 200-120 and Northeastern University
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Difflock Forum Index -> Jeep All times are GMT - 12 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot post calendar events in this forum
Adrian Flux 2019

Specialist Tools

Facebook

Evo Oils

Service Kits

Join our mailing list for upcoming events, special offers, discount coupons and expert advice on the latest 4x4 products!

* indicates required





    
Powered by phpBB © phpBB Group