FORUM CLASSIFIEDS DIFFLOCK.com Links & Networks
Forum Homepage
Log in
Profile
Search
Private Messages
Forum Members
Register
Classified Ads
Search Ads
Place New Ad
My ads
Place your classified
ads here for FREE
NB: Adverts placed in the general
forum areas will be deleted
Difflock Homepage
Online Shop
Contact Us
FAQ
Calendar
Garage
Facebook
Twitter
Youtube
Advertise With Us - Reach your target market by advertising on the Difflock.com forum.
Click here or call 0845 125 9407

4site4x4tyres.co.uk

Grand vitara glowplug light flashing. car wont start.
Goto page Previous  1, 2, 3, 4
 
 
Post new topic   Reply to topic    Difflock Forum Index -> Suzuki
View previous topic :: View next topic  
Author Message
blue0608
Gate Opener


Joined: 10 Jun 2015
Odometer: 1




PostPosted: Wed Jun 10, 2015 7:06 am    Post subject: Reply with quote

Googled the same problem and found this site so helpful. The engine is cranking and the glow plug light is flashing. I presume it's an immobiliser problem,. If anyone could forward on the information to me I would really appreciate it. Thanks in advance for any help Confused
Back to top
View user's profile Send private message
Keza
Gate Opener


Joined: 13 Aug 2015
Odometer: 4




PostPosted: Thu Aug 13, 2015 1:16 am    Post subject: Reply with quote

I'm having exactly the same problem!
My glow plug lights on my dash have started flashing and my jeep won't start its went to start for about 3 seconds and now the starter moter just spins over with no joy I have sprayed easy start into a air pipe which makes the engine almost run which makes me think it's not pumping diesel. My friend seems to think I might have damaged my key when I dropped it but I can't see any visible damage I have been looking on web forum ect which seems to think it could be a problem with the immoberliser which sounds expensive does anyone know how to disable it and isit possible to put it back once the problem is fixed?
If some one could pm me it would save me a lot of garage bills and make me a very happy lad again Smile
Back to top
View user's profile Send private message
Keza
Gate Opener


Joined: 13 Aug 2015
Odometer: 4




PostPosted: Thu Aug 13, 2015 5:24 pm    Post subject: Reply with quote

If anyone with the knowledge to do this could you please pm me or txt me as I am without a vehicle at the moment and am spending 28 pound a day on cabs to and from work
Back to top
View user's profile Send private message
zapcat
Gate Opener


Joined: 21 Aug 2015
Odometer: 1




PostPosted: Fri Aug 21, 2015 1:26 pm    Post subject: Reply with quote

Hello,

I have this problem too, would be really grateful if someone could pm or email me the way to bypass the immobiliser.

Thank you in advance!
Back to top
View user's profile Send private message
rhinoman
Mud Obsessed


Joined: 04 Sep 2004
Odometer: 3277
Location: Brinkworth, Wilts



PostPosted: Sat Aug 22, 2015 8:19 pm    Post subject: Reply with quote

I've tried the supposed bypass and it doesn't work, it will start the car but it will revert to limp mode and won't rev over 2500rpm. The problem is that these ECUs use an unusual memory chip for which there is no documentation so its not possible to fix it either. You need to source a replacement ECU, immo and lock set.
__________________________________
2000 Vitara 4u2, 3+3 lift, 33s, winch, safari rack, steel front axle and 5:83 R&Ps, LWB brakes
1986 SJ413K Pickup, 1.6 conversion
2006 Jimny JLX+, stock
Back to top
View user's profile Send private message Visit poster's website
Keza
Gate Opener


Joined: 13 Aug 2015
Odometer: 4




PostPosted: Sat Aug 22, 2015 11:56 pm    Post subject: Reply with quote

50 pound and problem was fixed was a faulty chip in my key mobile locksmith came reprogrammed a new chip and replaced my old on in the key Rolling Eyes Laughing
Back to top
View user's profile Send private message
flagger
Gate Opener


Joined: 08 Sep 2015
Odometer: 2




PostPosted: Tue Sep 08, 2015 12:00 pm    Post subject: Reply with quote

hi got the same problem with a grand vitara can you send me the how to disconnect the immobililizer

thanks jesper
Back to top
View user's profile Send private message
Kar1984
Gate Opener


Joined: 13 Sep 2015
Odometer: 1
Location: Penicuik



PostPosted: Sun Sep 13, 2015 4:50 pm    Post subject: Bypass Reply with quote

Hi their got same problem with glowplug light flashing tried everything please help thinking it may be immobiliser mitsubishi denso engine

Last edited by Kar1984 on Mon Sep 14, 2015 11:02 am; edited 1 time in total
Back to top
View user's profile Send private message
rhinoman
Mud Obsessed


Joined: 04 Sep 2004
Odometer: 3277
Location: Brinkworth, Wilts



PostPosted: Sun Sep 13, 2015 5:33 pm    Post subject: Reply with quote

You should pull the fault codes from the immo to find out what the fault is.
__________________________________
2000 Vitara 4u2, 3+3 lift, 33s, winch, safari rack, steel front axle and 5:83 R&Ps, LWB brakes
1986 SJ413K Pickup, 1.6 conversion
2006 Jimny JLX+, stock
Back to top
View user's profile Send private message Visit poster's website
flagger
Gate Opener


Joined: 08 Sep 2015
Odometer: 2




PostPosted: Wed Sep 16, 2015 11:37 am    Post subject: Reply with quote

hey is there nobody whohaves the guide to disconnect the immobilizer i really need it
thanks
jesper
Back to top
View user's profile Send private message
nwood3
Gate Opener


Joined: 17 Nov 2015
Odometer: 2
Location: Caterham



PostPosted: Tue Nov 17, 2015 8:40 pm    Post subject: Reply with quote

hi I have aslo got the same problem of the flashing glow plug indictor with my grand vitara would really appreciate if someone could send me the how to disconnect the immobililizer - really desperate - many thanks
__________________________________
Love dogs love walking but so desperately need my car
Back to top
View user's profile Send private message
nwood3
Gate Opener


Joined: 17 Nov 2015
Odometer: 2
Location: Caterham



PostPosted: Mon Nov 23, 2015 9:24 pm    Post subject: Glow Plug indicator flashing Reply with quote

Well I wasn't exactly overloaded with the zero amount of replies I received after my last post requesting information on how to disconnect the immobilizer on my Suzuki GV, but I am pleased to report that the fault has now been corrected and my car is back up and running. The fault was diagnosed in the ECU, which was put back to factory settings, and immediately I was able to start the engine and that was all for the cost of 65.00.
__________________________________
Love dogs love walking but so desperately need my car
Back to top
View user's profile Send private message
Xpajun
Mud Obsessed


Joined: 22 Sep 2008
Odometer: 3149



1988 Mitsubishi Shogun

PostPosted: Tue Nov 24, 2015 8:27 pm    Post subject: Re: Glow Plug indicator flashing Reply with quote

nwood3 wrote:
Well I wasn't exactly overloaded with the zero amount of replies I received after my last post requesting information on how to disconnect the immobilizer on my Suzuki GV, but I am pleased to report that the fault has now been corrected and my car is back up and running. The fault was diagnosed in the ECU, which was put back to factory settings, and immediately I was able to start the engine and that was all for the cost of 65.00.


So.........

As rinoman said then...
Back to top
View user's profile Send private message Visit poster's website eBay Name
eldred
Gate Opener


Joined: 28 Dec 2015
Odometer: 1




PostPosted: Tue Dec 29, 2015 9:30 am    Post subject: Reply with quote

sandyjet62 wrote:
Hi all, and thanks for all your help,

Well the problem is sorted now. Not by me I hasten to add, but by the very clever man I bought the car from. (as I said, a coleague at work). I knew it was an immobaliser problem, was quoted £100 + plus by Suzuki to look at it and approx £500 if it turned out to be the ecu.
Anyway, it turns out that if you have the RF engine and the immobiliser system has Denso ECU it is possible to dissconnect the immobiliser. In fact it is very easy to disable the immobiliser at no cost at all.
unfortunatley, i dont think it should be put up to open forum for the security of other GV owners with the same system. But I will gladly give the info to a mod and let them decide. It may not be a big secret but I could not find this info on the net anywhere, I was about to give up and look at replacing the unit the man with the plan came up with the solution.

Thanks again all.



Hi all. Sorry to drag up an old thread, having this same problem with my dad's car. Does anyone have the info on how to disconnect the immobiliser? Many thanks
Back to top
View user's profile Send private message
Xpajun
Mud Obsessed


Joined: 22 Sep 2008
Odometer: 3149



1988 Mitsubishi Shogun

PostPosted: Tue Dec 29, 2015 10:58 am    Post subject: Reply with quote

eldred wrote:
sandyjet62 wrote:
Hi all, and thanks for all your help,

Well the problem is sorted now. Not by me I hasten to add, but by the very clever man I bought the car from. (as I said, a coleague at work). I knew it was an immobaliser problem, was quoted £100 + plus by Suzuki to look at it and approx £500 if it turned out to be the ecu.
Anyway, it turns out that if you have the RF engine and the immobiliser system has Denso ECU it is possible to dissconnect the immobiliser. In fact it is very easy to disable the immobiliser at no cost at all.
unfortunatley, i dont think it should be put up to open forum for the security of other GV owners with the same system. But I will gladly give the info to a mod and let them decide. It may not be a big secret but I could not find this info on the net anywhere, I was about to give up and look at replacing the unit the man with the plan came up with the solution.

Thanks again all.



Hi all. Sorry to drag up an old thread, having this same problem with my dad's car. Does anyone have the info on how to disconnect the immobiliser? Many thanks


Try looking two post up Rolling Eyes
Back to top
View user's profile Send private message Visit poster's website eBay Name
Dominicjw1993
Gate Opener


Joined: 17 Jan 2016
Odometer: 12
Location: Leeds uk



PostPosted: Sun Jan 17, 2016 1:06 pm    Post subject: Reply with quote

Hi I have a 1998 2.0td with the same problem just wondering if you can help took it to the garage they where baffled
Cheers
Dom
Back to top
View user's profile Send private message Skype Name
mudonboots
Gate Opener


Joined: 29 Jan 2016
Odometer: 2




PostPosted: Sat Jan 30, 2016 10:07 am    Post subject: grand vitara glowplug light flashing Reply with quote

Hi everyone ! I have the same problem as everyone else , been rebooting the immobiliser for quite a few years now and it is now not rebooting ! anyone who has the info to fix this please send me a pm thanks
Back to top
View user's profile Send private message
mudonboots
Gate Opener


Joined: 29 Jan 2016
Odometer: 2




PostPosted: Tue Feb 09, 2016 11:55 am    Post subject: suzuki grand vitara 20TD glowplug light flashing wont start Reply with quote

Hi Guys I have a Grand vitara TD with the mazda engine , the glowplug light is flashing and the car will not start . I have had a chap come out and plug his diognostic equipment in but the codes he gets are not right as the car is a manual and the codes are for an auto ! also the ECU will not reset ? I think this is an immobiliser problem the car tries to fire but will just not go ! any sugestions ?
Back to top
View user's profile Send private message
00bjz00
Gate Opener


Joined: 05 Jun 2016
Odometer: 1




PostPosted: Sun Jun 05, 2016 8:53 am    Post subject: Reply with quote

Hello there! (Greetings from Portugal!)

GV 1999 - Mazda RF Engine & Denso ECU (or ECM).

Almost same problem here.

We've replaced the ECU (or ECM) and made immo off.

But it won't start either.

After reading the entire post, I wonder if I need to change something where we insert the key (key ignition? or key ring? or something like that?).

Help needed!

Greetings and thanks in advance.
Back to top
View user's profile Send private message
iulian
Gate Opener


Joined: 05 Dec 2016
Odometer: 2
Location: Romania



PostPosted: Mon Dec 05, 2016 8:36 pm    Post subject: Same problem here Reply with quote

Hello everybody,

Went to a nice trip in the mountains, all was fine until reaching home. Trying to start the car, I noticed the glowplug light flashing and the engine turning, but not starting.
I really like the GV's classic offroader style, with separate chassis, transfer case and solid axle and would like to solve the issue. MY GV is 2001 year, RF Mazda engine.
Not to mention I am a Suzuki fan, owning a modified Samurai for serious offroading, which fortunately is still possible here.
I am kindly ask you to PM and help me solving the immobiliser bypass.
Thanks in advance,
Iulian
Back to top
View user's profile Send private message Send e-mail
iulian
Gate Opener


Joined: 05 Dec 2016
Odometer: 2
Location: Romania



PostPosted: Tue Dec 27, 2016 10:12 pm    Post subject: Reply with quote

I got 83 error code, but in the end I managed to start the car using the 10 times putting contact method, big thanks to the users sharing this method.
Still, I would like to solve the issue with immo and would be very grateful if someone would pm me the method.
Thanks,
Iulian
Back to top
View user's profile Send private message Send e-mail
billy1000
Gate Opener


Joined: 13 Jan 2017
Odometer: 1




PostPosted: Fri Jan 13, 2017 4:08 pm    Post subject: flashy glow plug light Reply with quote

Hi all I found this site on a search as I have the same problem with the glow plug light flashing and the ****** wont start
I have a 1999 grand vitara 2.0 diesel
can some one be so kind to send me the bypass instructions for the immobilizer before I go monty python on the dam thing as it driving me nutz

cheers
Back to top
View user's profile Send private message
Mrcirrus
Gate Opener


Joined: 17 Apr 2017
Odometer: 1




PostPosted: Mon Apr 17, 2017 8:59 pm    Post subject: Flashing Glow Plug Reply with quote

I love my Vitara because it's so reliable, until now. Flashing glow plug engine fires then cuts out. Worse thing is im on holiday in Slovakia with a glider trailer to get back to the UK with. My mates a mechanic and we found the relay (green relay on right side of bay looking forwards) cleaned it, by passed it, no good. We disconnected battery...no good. Eventually it just started...thank god. Tempted to leave it running for the week we are here but cannot afford the diesel!! Please Please can somebody PM me the immobiliser bypass trick....just n case it happens again.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Difflock Forum Index -> Suzuki All times are GMT - 12 Hours
Goto page Previous  1, 2, 3, 4
Page 4 of 4

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot post calendar events in this forum
Evo Oils

Facebook

Oil Safe

Specialist Tools

Service Kits

Join our mailing list for upcoming events, special offers, discount coupons and expert advice on the latest 4x4 products!

* indicates required



4site4x4tyres.co.uk


    
Powered by phpBB © phpBB Group